struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From fullmit...@lycos.com
Subject Re: CDI Plugin example does not work in 2.5.14.1
Date Mon, 22 Jan 2018 19:38:06 GMT
Oracle support has created a bug for this issue:
BUG 27424564 - STRUTS 2.5.14.1 APP BROKEN AT SOME POINT AFTER PSU 
12.1.3.0.160719
I tried downgrading the Weblogic PSU and that appears to work.  One can 
also downgrade the Struts version. Struts 2.5.12 works for me with the 
latest Weblogic PSU. (27057030).

On 2018-01-22 18:11, fullmitten@lycos.com wrote:

> I am using Java 1.8.0_131-b11 on Windows 7, 64-bit for both building 
> the app and running Weblogic.
> 
> I did some more experimenting. I tried removing CDI from my source code 
> and the Maven pom.  I still get the error with a complete stripped down 
> application (the only dependency being Struts), so CDI isn't at issue 
> here.
> 
> The word from Oracle is that this problem appears to have been 
> introduced into WLS 12.1.3 between the July 2016 and January 2018 
> Critical Patch Updates (that is, Struts works with the earlier patch 
> and does not work with the latter). I, of course, am running with the 
> latest updates.
> Thanks.
> 
> On 2018-01-21 14:32, Lukasz Lenart wrote:
...

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message