struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Zepernick <Paul.Zepern...@healthsmart.com>
Subject RE: Struts2.x ActionError And ActionMessage
Date Thu, 16 Nov 2017 15:28:17 GMT
ActionError and ActionMessage are not classes you can utilize stand alone.  Calling addActionError()
is actually building a List<String> in the action and same with addActionMessage().
 Are you trying to validate a Struts action or something entirely different, since you say
the validation is not done in your action class?  Maybe you need to pass the instance of your
action class to the class that you have doing the validation?

-----Original Message-----
From: Adam Brin [mailto:abrin@digitalantiquity.org]
Sent: Thursday, November 16, 2017 10:19 AM
To: Struts Users Mailing List <user@struts.apache.org>
Subject: Re: Struts2.x ActionError And ActionMessage

Hi Siva,
  Can you share an example of what you’re doing and what’s not working?

thanks,

adam
--
_________________________________________________________
Adam Brin
Director of Technology, Digital Antiquity
480.965.1278

> On Nov 16, 2017, at 8:15 AM, Dhulipudi, Sivannarayana <sivannarayana.dhulipudi@cgi.com>
wrote:
>
> Hi All,
>
> I tried to use struts 2.x  ActionError and ActonMessage classes to do validations.
>
> I saw a lot examples on internet, in those examples adding errors and
> messages to actionsupport class like
>
> addActionErrors() and addActionMessage(). but I want to use ActionError and ActionMessage
classes in my project.
>
> I'm not doing validation in action class . please help me someone on this topic.
>
> Thanks
> Siva
>
>
> ________________________________________
> From: Lukasz Lenart [lukaszlenart@apache.org]
> Sent: Wednesday, November 15, 2017 11:52 PM
> To: Struts Users Mailing List
> Subject: Re: Migration from Struts1 to Struts2.5
>
> 2017-11-15 16:26 GMT+01:00 JK <janakiramkjr@gmail.com>:
>> struts2-core-2.5.13.jar
>> struts2-tiles-plugin-2.3.8.jar
>> tiles-core-2.0.6.jar
>> tiles-jsp-2.0.6.jar
>> tiles-api-2.0.6.jar
>
> You are using a wrong version of Tiles, Struts 2.5.13 and the Struts 2
> Tiles plugin based on Tiles 3 - you must use Tiles 3.0.7 at least
> http://struts.apache.org/maven/struts2-plugins/struts2-tiles-plugin/de
> pendency-management.html
>
>
> Regards
> --
> Łukasz
> + 48 606 323 122 http://www.lenart.org.pl/
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org




Disclaimer: This communication and any files transmitted with it may contain information that
is privileged, confidential and/or exempt from disclosure under applicable law. If you are
not the intended recipient, you are hereby notified that any disclosure, copying, distribution,
or use of the information contained herein (including any reliance thereon) is strictly prohibited.
If you received this communication in error, please immediately contact the sender and destroy
the material in its entirety, whether in electronic or hard copy format. Thank you.
Mime
View raw message