struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yasser Zamani <yasser.zam...@live.com>
Subject Re: No container in actions after upgrading to 2.5.13
Date Tue, 12 Sep 2017 09:43:24 GMT
No, "DEBUG" level is not interesting for me now. Also, as I saw, it 
seems this specific message is not dependent to devMode value [1].

Could you please reduce your log4j2 root level to only log "WARN" ? so 
it'll be less puffy and simpler to examine.

Then please check if devMode works, open 
http://yourIp:yourPort/yourContextPath/oneOfYourAction?iDontExist=test 
in your browser. while that one action does not have iDontExist 
property, I think you should see a warning from ParametersInterceptor on 
output.

[1] 
https://github.com/apache/struts/blob/master/core/src/main/java/com/opensymphony/xwork2/util/AbstractLocalizedTextProvider.java#L266

On 9/12/2017 1:17 PM, LAW Andy wrote:
>
>> On 11 Sep 2017, at 22:50, LAW Andy <andy.law@roslin.ed.ac.uk> wrote:
>>
>>
>>>
>>> Did you try "devmode=true" and then examining output for any warning?
>>
>>
>> I did. And there’s nothing obvious.
>>
>
> Scrub that - there is something coming up (I think I must have been looking at the wrong
debug output last night).
>
> 6727 [http-nio-8082-exec-5] DEBUG com.opensymphony.xwork2.util.AbstractLocalizedTextProvider
[] - Base class org.apache.catalina.loader.WebappClassLoader doesn't contain 'resourceEntries'
field, trying with parent!
> java.lang.NoSuchFieldException: resourceEntries
>
>
> OK. That gives me a start.
>
>
> Later,
>
> Andy
>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org
Mime
View raw message