struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yasser Zamani <yasser.zam...@live.com>
Subject Re: Which Struts Version To Use?
Date Mon, 18 Sep 2017 15:33:28 GMT


On 9/18/2017 7:35 PM, Phillips, Bruce A wrote:
> We still have a couple of web apps that are using Struts version 2.3.32
> 
> We want to update those web apps to the latest version of Struts but I’m not sure what
version to update to.
> 
> I see a 2.5.13 and a 2.3.34 – both tags seem to be recently created.
> 
> Should I update to 2.5.13 or should I stay on the 2.3.X line?
> 
> Why are there different production tags (2.5.X and 2.3.X) ?

Because The 2.5.x series introduced some breaking changes, so the 
development is now branching, as 2.3.x is still supported. Basically we 
backport some security fixes to 2.3.x without breaking things.

So you can update to 2.3.34 without any needed change but you will not 
get any further bug fixes but only security fixes. But if you update to 
2.5.13, then you need to do a few migration steps at [1], and then you 
will get future both security and bug fixes.

I recommend updating to 2.5.13 as I already test [1] on our app and all 
of our JMeter functional tests pass in it also.

Hope this helps.

[1] https://struts.apache.org/docs/struts-23-to-25-migration.html


> 
> Thank You,
> 
> Bruce Phillips
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org
Mime
View raw message