struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From programmie...@gmx.ch
Subject Re: Tiles: Upgrade from struts2-tiles3-plugin to struts2-tiles-plugin gives a NoSuchDefinitionException => Same Problem can be reproduces with struts2-showcase-2.5.10.1
Date Wed, 12 Apr 2017 18:57:38 GMT
I tried 3 different Tomcat versions on Windows 10. Version 6.0.47,
7.0.72 and 9.0.0.M13. All Versions had the same behaviour (tiles of
struts2-showcase-2.5.10.1 is not working, NoSuchDefinitionException is
thrown). 

But: It is working fine when I define the config by hand! :) 

Running on Windows 10 seems to require the config by hand - on linux
it's working without. 

Regards 

Ralph 

Am 2017-04-12 08:27, schrieb Lukasz Lenart:

> 2017-04-11 16:24 GMT+02:00  <programmierer@gmx.ch>: 
> 
>> On Linux (Ubuntu 16.4): struts2-tiles-plugin (Version 2.5.10.1) works
>> fine => same source (same war-file) and same Tomcat-Version
> 
> Did you try to use a different Tomcat version? Did you try to define
> configs by hand?
> 
> <context-param>
> <param-name>org.apache.tiles.definition.DefinitionsFactory.DEFINITIONS_CONFIG</param-name>
> <param-value>
> /WEB-INF/tiles-1.xml,
> /WEB-INF/tiles-2.xml,
> /WEB-INF/tiles-3.xml,
> /WEB-INF/tiles-4.xml
> </param-value>
> </context-param>
> 
> Regards
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message