struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Evans <dsevan...@gmail.com>
Subject Re: Download jar - All dependencies vs Essential dependencies
Date Tue, 18 Apr 2017 12:08:23 GMT
I'm sorry, I should have done a better job phrasing my question.

There are two jars which I can download, struts-2.5.10.1-lib.zip and
struts-2.5.10.1-min-lib.zip.  What are the use cases for these two
jars? I'd like to use the "Essential Dependencies" version, and would
like to know what would require that someone use the "All
Dependencies" version.

Dave

On Tue, Apr 18, 2017 at 1:28 AM, Lukasz Lenart <lukaszlenart@apache.org> wrote:
> 2017-04-18 4:19 GMT+02:00 Dave Evans <dsevans93@gmail.com>:
>> Hello,
>>
>> I have a very minimal struts app I wrote some years ago. I want to
>> upgrade it from 2.3 to 2.5.  I'm wondering what requirements would
>> allow the use of the essential dependencies jar. I am using only jstl
>> tags, no struts tags. And my app is pretty simple.
>
> There are an essential dependencies to download, is that what are you
> looking for?
> http://struts.apache.org/download.cgi#struts-ga
>
> All the tags are included in the struts2-core.jar, there is a plan to
> exclude them into plugins and have just pure core MVC engine.
>
>
> Regards
> --
> Ɓukasz
> + 48 606 323 122 http://www.lenart.org.pl/
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message