struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Java House <java4...@gmail.com>
Subject Blank app fails to build
Date Sun, 20 Nov 2016 09:51:10 GMT
Hello

this is my first attempt with Struts.
I am trying to run the Blank App sample application. I tried first by
creating it using the maven archetype and also tried it through the
struts-examples-master.
I am using
JDK 1.8.0_111,
mvn 3.3.9
Struts 2.5.5

when doing mvn clean install
test fails on the getText() method, I am getting null pointer exception
-------------------------------------------------------
 T E S T S
-------------------------------------------------------
Running example.ConfigTest
Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.886
sec - in example.ConfigTest
Running example.HelloWorldTest
Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 0.083
sec <<< FAILURE! - in example.HelloWorldTest
testHelloWorld(example.HelloWorldTest)  Time elapsed: 0.082 sec  <<< ERROR!
java.lang.NullPointerException
    at example.HelloWorldTest.testHelloWorld(HelloWorldTest.java:31)


I also tried a few older versions of struts but I am always getting
this error. Does anyone has any idea what am I doing wrong?

I am guessing that the getText method fails because it does not find
the properties files.
In the example the properties is under
struts-examples-master\blank\src\main\resources\example\package.properties

I even tried to place the file under the java and rename it the same
as the class
struts-examples-master\blank\src\main\java\example\HelloWorld.properties

but it didn't help

thank you for your support

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message