struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sreekanth S. Nair" <sreekanth.n...@egovernments.org>
Subject Re: Struts2 initial page loading time
Date Thu, 21 Jul 2016 06:22:43 GMT
May be... We are using strust2-spring-plugin. I'm not pretty sure about
this plugin internal, need to investigate on this where its spending time.

On Thu, Jul 21, 2016 at 11:45 AM, Lukasz Lenart <lukaszlenart@apache.org>
wrote:

> 2016-07-21 7:58 GMT+02:00 Sreekanth S. Nair <
> sreekanth.nair@egovernments.org>:
> > Hi Adam,
> >                I don't think a blank artifact can replicate the issue, in
> > our app action consist of many spring beans dependency and so on. As i
> said
> > this is happening only while first time a page loads from a web context,
> > later on any pages from the same web context loads normal. I guess struts
> > is doing some warming up wrt spring bean injection or something similar.
>
> I would say that the Spring is doing some warmup (e.g. building object
> graph), if you are using the Spring to construct actions and inject
> dependencies, Struts has nothing to do here. Maybe it is possible to
> configure Spring to avoid package-scan (which is slow and performed on
> init).
>
>
> Regards
> --
> Ɓukasz
> + 48 606 323 122 http://www.lenart.org.pl/
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message