struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lukasz Lenart <>
Subject Re: Can't use 'expand' on struts 2 debug browser output
Date Thu, 14 Aug 2014 05:42:28 GMT
2014-08-14 1:09 GMT+02:00 Ralph Cook <>:
> I am working with the basic_struts example application, attempting to study
> the debugging tools in Struts 2. I have done the following:
> put <s:head /> within my <head> tags
> put struts2-dojo-plugin in my maven dependencies
> put "?debug=browser" at the end of a link to be clicked on
> When I click on the link, it displays the debug page, with a number of links
> labelled "Expand".  No errors show up in the console.  When I hover over the
> "Expand" links, they show "javascript://nop/"; when I click on them, I can't
> see that anything happens. I tried a number of different ones.
> When I look at the source for the page, I can see that there is javascript
> to execute when the Expand link is clicked. I attempted to enter the Chrome
> debugger, but I don't know how to open the source so that I can set a
> breakpoint.
> So, does someone know something else to do that a newbie might forget? Or
> can someone please point me to some kind of troubleshooting method?
> rc

There was few issue around (Dojo plugin is broken after migrating to
Git, Debug console had some issues) so I migrate Debug Console to
jQuery and fixed it

You can try the latest snapshot

+ 48 606 323 122

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message