struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lukasz Lenart <lukaszlen...@apache.org>
Subject Re: [ANN] Struts 2.3.16.3 GA release available - security fix
Date Sun, 11 May 2014 10:55:39 GMT
My mistake, 2.3.16.2 is affected as well. The question is do you use
CookieInterceptor and do you use "*" to catch all  cookies? If both
answer are yes, you should upgrade.

2014-05-08 11:31 GMT+02:00 Tamer Erdogan <Tamer.Erdogan@vasco.com>:
> If we have 2.3.16.2 installed, should we also update to 2.3.16.3. Because in S2-022 2.3.16.2
is not in affected version.
>
> Regards
> Tamer
>
> -----Original Message-----
> From: Lukasz Lenart [mailto:lukaszlenart@apache.org]
> Sent: Monday, May 5, 2014 16:33
> To: Struts Users Mailing List; Struts Developers List; announcements@struts.apache.org;
security@apache.org; full-disclosure@lists.grok.org.uk; bugtraq@securityfocus.com
> Subject: [ANN] Struts 2.3.16.3 GA release available - security fix
>
> The Apache Struts group is pleased to announce that Struts 2.3.16.3 is available as a
"General Availability" release.The GA designation is our highest quality grade.
>
> Apache Struts 2 is an elegant, extensible framework for creating enterprise-ready Java
web applications. The framework is designed to streamline the full development cycle, from
building, to deploying, to maintaining applications over time.
>
> This release includes important security fixes:
> - S2-022 - Extends excluded params to avoid manipulation of Struts'
> internals via CookieInterceptor
>
> * http://struts.apache.org/release/2.3.x/docs/s2-022.html
>
> All developers are strongly advised to update existing Struts 2 applications to Struts
2.3.16.3
>
> Struts 2.3.16.3 is available in a full distribution, or as separate library, source,
example and documentation distributions, from the releases page.
> * http://struts.apache.org/download.cgi#struts23163
>
> The release is also available from the central Maven repository under Group ID "org.apache.struts".
>
> The 2.3.x series of the Apache Struts framework has a minimum requirement of the following
specification versions:
> * Java Servlet 2.4 and JavaServer Pages (JSP) 2.0
> * Java 2 Standard Platform Edition (J2SE) 5
>
> The release notes are available online at:
> * http://struts.apache.org/release/2.3.x/docs/version-notes-23163.html
>
> Should any issues arise with your use of any version of the Struts framework, please
post your comments to the user list, and, if appropriate, file a tracking ticket.appropriate,
file a tracking
> ticket:
> * https://issues.apache.org/jira/browse/WW
>
>
> - The Apache Struts group.
>
>
> Regards
> --
> Ɓukasz
> + 48 606 323 122 http://www.lenart.org.pl/
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message