struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fredrik Andersson <fredan...@hotmail.com>
Subject RE: Why do I get this XHTML validation errors? (second attempt)
Date Fri, 07 Mar 2014 20:03:00 GMT
Hello guys!

I think you solved it!

I put a new file "hidden.ftl" in my resources-folder (I use maven with eclipse):
resources/template/xhtml/hidden.ftl

The content in hidden.ftl is:

<tr style="display:none;">
	<td>
		<#include "/${parameters.templateDir}/simple/hidden.ftl" />
	</td>
</tr>

Now it validates fine!

Best regards
Fredrik



----------------------------------------
> From: thechrispratt@gmail.com
> Date: Thu, 6 Mar 2014 12:45:00 -0800
> Subject: Re: Re: Why do I get this XHTML validation errors? (second attempt)
> To: user@struts.apache.org
>
> To elaborate on Dave's point, try:
>
> <tr style="display:none;">
> <td>
> // both hidden fields
> </td>
> </tr>
>
> (*Chris*)
>
>
> On Thu, Mar 6, 2014 at 12:26 PM, Dave Newton <davelnewton@gmail.com> wrote:
>
>> On Thu, Mar 6, 2014 at 3:01 PM, Fredrik Andersson <fredand44@hotmail.com
>>>wrote:
>>
>>> I have tride to put the hidden attributet att:
>>> 1 first code line after the form-start-tag
>>> 2 before the submit-tag
>>> 3 after the submit-tag, before form-end-tag.
>>> None of the attempt validates.
>>> So If you guys got any idea how to solve this mystery plast let me know.
>>>
>>
>> You could try what I suggested until the hidden tags have xhtml templates
>> that emit correct HTML.
>>
>> Dave
>> 		 	   		  
---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message