struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Newton <davelnew...@gmail.com>
Subject Re: Problem with tutorial
Date Sun, 24 Nov 2013 04:47:15 GMT
Does *any* EL work? What's your web.xml app (servlet spec) version?
 On Nov 23, 2013 5:43 PM, "Michel Prévost" <prevost_michel@hotmail.com>
wrote:

> I am new to struts and going through the
> http://struts.apache.org/release/2.3.x/docs/using-struts-2-tags.html
> tutorial. I have a problem where a var is not expanded.
>
> Ex:
>
>                 <s:url action="hello" var="helloLink">
>                         <s:param name="userName">Bruce Phillips</s:param>
>                 </s:url>
>
>                 <a href="${helloLink}">Hello Bruce Phillips</a>
>
> Normally, when hovering the produced link I should see:
> http://localhost:8080/basic_struts/hello.action?userName=Bruce+Phillips
>
> What I see is: http://localhost:8080/basic_struts/$%7B helloLink%7D
>
> As you can see, the var is not expanded and the server returns the href as
> is, instead of expanding it to the action="hello" url specification.
>
> I run Tomcat 7, with struts 2.3.15.3.
>
> Some suggested to use ELIgnored="false" and isELIgnored="false" in the Page
> directive, but those attributes are not regocnized (Eclipse draws yellow
> doodles under it ).
>
> Thank you,
> Michel
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message