struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Pratt <thechrispr...@gmail.com>
Subject Re: s:url & s:param does not work on struts 2.3.15.1
Date Mon, 19 Aug 2013 17:44:50 GMT
It might even work using <s:param name="state.name">*$*{stateName}</s:param>.
 But, like Dave I don't think the tag body is searched for OGNL expressions.
  (*Chris*)


On Mon, Aug 19, 2013 at 10:34 AM, Dave Newton <davelnewton@gmail.com> wrote:

> Does it work if you use:
>
>     <s:param name="state.name" value="%{stateName}"/>
>
> I actually didn't know it'd work with an OGNL expression as a tag body.
>
> Dave
>
>
>
> On Mon, Aug 19, 2013 at 1:22 PM, Omar Ngarigari <ngarigarius@yahoo.com
> >wrote:
>
> > Hello,
> >
> > I am in the process of upgrading my struts2.3.1.2 application to
> > struts2.3.15.1. Everything works fine except the <s:url> and <s:param>
> tags.
> >
> > In struts2.3.1.2, I have the following code in jsp file
> > <s:url var "add" action="addState">
> >           <s:param name="state.name">%{stateName}</s:param>
> > </s:url>
> > <s:a href="%{add}">Add</s:a>
> >
> > I used to get correct state name when using struts2.3.1.2. However, using
> > struts2.3.15.1, I am getting the following on web-browser page:
> %{stateName}
> >
> >
> > Thanks,
> >
> > Omar N.
> >
>
>
>
> --
> e: davelnewton@gmail.com
> m: 908-380-8699
> s: davelnewton_skype
> t: @dave_newton <https://twitter.com/dave_newton>
> b: Bucky Bits <http://buckybits.blogspot.com/>
> g: davelnewton <https://github.com/davelnewton>
> so: Dave Newton <http://stackoverflow.com/users/438992/dave-newton>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message