struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alireza Fattahi <afatt...@yahoo.com>
Subject Re: json validation with utf-8 error messages
Date Mon, 15 Jul 2013 09:27:32 GMT
Hi,

I used to save the messages.resources with UTF-8 encoding
and the <s:text name="some.text" /> showed correctly but the json validation messages
not!

I saved mesages.resource with ansi encoding and chaned all strings from native to ascii (
by http://native2ascii.net/ )
the json validation messages displayed correctly but the <s:text name="some.text" /> 
did not show correct messages, just question marks.

I added <%@ page contentType="text/html; charset=utf-8" %> to the page and now I have
correct  json validation messages AND  <s:text name="some.text" />

I don't know is it best practice or not.



 
~Regards,
~~Alireza Fattahi


________________________________
 From: Lukasz Lenart <lukaszlenart@apache.org>
To: Struts Users Mailing List <user@struts.apache.org> 
Sent: Monday, 15 July 2013, 13:30
Subject: Re: json validation with utf-8 error messages
 

2013/7/15 Alireza Fattahi <afattahi@yahoo.com>:
> Any comments?!

Any example?!?!?!?!?!?!


Regards
-- 
Łukasz
+ 48 606 323 122 http://www.lenart.org.pl/

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message