struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Litman, Bruno" <blit...@alabamainteractive.org>
Subject RE: s:action tag showing result
Date Fri, 21 Jun 2013 22:04:00 GMT
We are also experiencing issues with tags and theme files, we are upgrading many applications
from 2.3.4.1 to 2.3.14.3
I am not sure if this is related - if not and if I need to start a new discussion please let
me know and accept my apology.

1/ 

We previously always coded forms as : 
	<s:form action="login" namespace="/">....
Now randomly, this fails to generate the proper action url in the html (it is missing the
'.action', which results in a 404 once you post the form)

The only workaround we have found so far is to add the '.action' suffix to the s:form's action
attribute. Before it was always added for us by struts. 
So now we are having success with 
	<s:form action="login.action" namespace="/">...

Is this expected behavior? Did this change recently? 2.3.4.1 is not so ancient..

2/ 

We are trying to replace the "required" attribute in the textfields with "requiredLabel" without
success. Was the xhtml theme's ftl file "controlheader_core" updated to reflect the changes
in the struts-tags.tld (requiredLabel replaced required)? 

Also, it seems applications are randomly serving ftl files from other applications' theme
folders with the same name.
 This was demonstrated by modifying something obvious in one application's ftl file (displaying
some text next to a text field's label), and the effect can be seen randomly on other applications
which shouldn’t even see that application's template folder (the themes are however named
the same in both applications)
I am only able to make the "requiredLabel" attribute work if placed in a <s:param> tag
as opposed to being just an attribute of the s:textfield tag, but even so it is still not
always using the same ftl files (however always from similarly named themes placed inside
each application)

This is extremely confusing. Is FreeMarker caching files independently of the application?
Is the app container interfering with caching? (We are using Resin 4.0.36)

Any help would be greatly appreciated
Thank you in advance

Bruno Litman

-----Original Message-----
From: Daniel Clemente Ivars [mailto:daniel.clemente@boluda.com.es] 
Sent: Friday, June 21, 2013 7:43 AM
To: Struts Users Mailing List
Subject: Re: s:action tag showing result

I agree with Felipe. In version 2.3.8 all was fine, but from 2.3.12 all the problems with
tags begun (action tags and field tags).

Thanks

 
Daniel Clemente Ivars




De:     Felipe Lorenz <felipe.lorenz@idealogic.com.br>
Para:   "Struts Users Mailing List" <user@struts.apache.org>, 
Fecha:  21/06/2013 14:30
Asunto: Re: s:action tag showing result



Hi Lukasz,

I try struts v. 2.3.8, and everything works fine. But, the first version I've notice this
strange behaviour was 2.3.12.

I try to find the ftl file for the action tag, but I could no find it. 
There is a special file? How does it works?

Thanks,

Felipe Lorenz
Gerente de Projetos
Idealogic Software
Fone: (51) 3715 5523 - (51) 3715 5548
www.idealogic.com.br

Em 21/06/2013, às 02:34, Lukasz Lenart escreveu:

> Have you tried to use the previous versions?
> 
> 
> Regards
> --
> Łukasz
> + 48 606 323 122 http://www.lenart.org.pl/
> 
> 2013/6/20 Felipe Lorenz <felipe.lorenz@idealogic.com.br>:
>> Hi all,
>> 
>> I have been using struts quite a long time, but in the last days I 
>> have
faced a strange behaviour of s:action tag.
>> 
>> In my JSP I am using the tag action to load list to be used to mount 
>> my
s:select. But in the redered HTML, the result of the action is showing, even when the executeResult
is false.
>> 
>> There is something I missing?
>> 
>> 
>> JSP code:
>> 
>> <s:action namespace="/ajax" name="loadEstadoByPais" var="estado" 
flush="false" />
>> <s:select
>>                        label="%{getText('global.lbl_nmEstado')}"
>>                        name="cidade.estado.idEstado"
>>                        listKey="idEstado"
>>                        listValue="nmEstado"
>>                        list="#estado.estados"
>>                        emptyOption="true"
>>                        id="estadoCombo"
>>                        tooltip="%{getText('global.hint_nmEstado')}"/>
>> 
>> struts.xml:
>> 
>> <action name="loadEstadoByPais" method="loadEstadoByPais" 
class="br.com.seedingControl.action.EstadoAction">
>>        <result name="index" type="json">
>>                <param name="includeProperties">
>>                        ^estados\[\d+\]\.idEstado,
>>                        ^estados\[\d+\]\.nmEstado
>>                </param>
>>        </result>
>> </action>
>> 
>> As you can see, in the struts.xml, I have only json result, and I 
>> only
need as json, but when I use the action tag, I just only need the populated list to be used
in the select tag. It is working very well, but the problem is that the json result is showing
in the HTML. And it is showing in the top, not in the action tag position, what is strange.
>> 
>> Also, I try to change the struts.devMode to false, but nothing changes.
>> 
>> The project is using struts 2.3.14.3 with rest-plugin. But for this
kind ok action, I avoid rest and use just json-plugin.
>> 
>> Please, if need any further info, ask me!
>> 
>> Thanks in advance.
>> 
>> 
>> Felipe Lorenz
>> 
>> 
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
>> For additional commands, e-mail: user-help@struts.apache.org
>> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
> 



.
.
Mime
View raw message