struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sekar, Sowmya" <sse...@ucsd.edu>
Subject RE: Struts 1.1 and Tiles 2 compatability
Date Mon, 11 Mar 2013 20:34:54 GMT
Is any version of Struts 1 (example : Struts 1.4) compatible with Tiles 2.2.2.? 

Thanks, Sowmya

-----Original Message-----
From: paulus.benedictus@gmail.com [mailto:paulus.benedictus@gmail.com] On Behalf Of Paul Benedict
Sent: Monday, March 11, 2013 1:15 PM
To: Struts Users Mailing List
Subject: Re: Struts 1.1 and Tiles 2 compatability

Tiles 2 is not compatible with Struts 1. You must use Tiles 1.

Paul

On Mon, Mar 11, 2013 at 3:01 PM, Sekar, Sowmya <ssekar@ucsd.edu> wrote:

> Hi,
>
> I am in the process of upgrading from Tiles 1 to Tiles 2.2.2 combined 
> with Struts 1.1.
>
> I have the following configuration in struts-config.xml
>
> <controller
> processorClass="org.apache.struts.tiles.TilesRequestProcessor"/>
>
>   <plug-in className="org.apache.struts.tiles.TilesPlugin" >
>     <set-property property="definitions-config"
> value="/WEB-INF/tiles.xml"/>
>     <set-property property="moduleAware" value="true" />
>     <set-property property="definitions-parser-validate" value="true" />
>   </plug-in>
>
> Below is the dtd configured in tiles.xml
>
> <!DOCTYPE tiles-definitions PUBLIC
>        "-//Apache Software Foundation//DTD Tiles Configuration 2.0//EN"
>        "http://tiles.apache.org/dtds/tiles-config_2_0.dtd">
>
> I have the tiles2.2.2 related jars(tiles-jsp, tiles-servlet, 
> tiles-template, tiles-api, tiles-core) in my classpath and I use maven 
> to import jars in my project
>
> When I start tomcat and display my page, I get the following error,
>
> Mar 11, 2013 12:54:52 PM 
> org.apache.catalina.core.ApplicationDispatcher
> invoke
> SEVERE: Servlet.service() for servlet jsp threw exception
> org.apache.tiles.template.NoSuchAttributeException: Attribute 'topmenu'
> not found.
>        at
> org.apache.tiles.template.DefaultAttributeResolver.computeAttribute(DefaultAttributeResolver.java:49)
>        at
> org.apache.tiles.template.InsertAttributeModel.resolveAttribute(InsertAttributeModel.java:187)
>        at
> org.apache.tiles.template.InsertAttributeModel.start(InsertAttributeMo
> del.java:107)
>
> It is not able to find any of the attributes in tiles.xml
>
> Any thoughts?
>
> Thanks,
> Sowmya
> ssekar@ucsd.edu
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message