struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "J.V." <jvsr...@gmail.com>
Subject Re: DynaValidatorActionForm (using Apache Commons Validator project)
Date Thu, 21 Mar 2013 21:28:59 GMT
I must be doing something wrong.  Any ideas?

When I hit submit on the form (and leave the fields empty), it continues
with the lines in the Action method and never validates.

Is there anything wrong with this configuration at all?

---
 My struts-config.xml entry looks like this:
  
  <form-bean name="loginFormBean" type="com.my.form.LoginForm">
            <form-property name="username" type="java.lang.String"/>
            <form-property name="password" type="java.lang.String"
  </form-bean>
		
--- My validators-user.xml entry looks like this
		
	<form-validation>
		<formset>

        
        <form name="loginFormBean">
            <field property="username" depends="required">
                <msg name="required" key="error.validation.userName"/>
            </field>
            <field property="password" depends="required">
                <msg name="required" key="error.validation.password"/>
            </field>
        </form>

....
		




--
View this message in context: http://struts.1045723.n5.nabble.com/DynaValidatorActionForm-using-Apache-Commons-Validator-project-tp5712255p5712258.html
Sent from the Struts - User mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message