struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Philippe Lagardere <>
Subject Re: [2.3.8] Parameters interceptor tampering with file upload ?
Date Thu, 17 Jan 2013 13:10:40 GMT
Hi again,

I eventually solved the 'problem'. It turns out it had nothing to do
with Struts, and everything to do with misplaced code.

After searching for interference from Tiles, I realized the form for
the file upload was included inside another form. After relocating the
form, it works exactly as intended.

I am a bit ashamed, and definitely sorry for using the mailing list
because of such a silly mistake.


2013/1/16 Philippe Lagardere <>:
> Hello,
> The server was not a good track - apparently Tomcats can manage
> multipart/form-data natively. The only configuration I could find
> revolved around setting up the directory to send the file to, as well
> as restricting the allowed file size or type.
> I tried setting up a file upload form on a mint project. That worked
> straight away.
> I added my custom converters, it still worked. I then added the custom
> interceptor... still OK.
> At this point, there are a few things remaining to test, but I'm
> sceptical as to how they could be related :
>    - Tiles integration (with struts-tiles-plugin in matching version
> and StrutsTilesListener declared in web.xml)
>    - Fiddling with other custom interceptors (but they are not reached
> when the exception is raised)
>    - Using the same form but in other JSP pages
> By any chance, does anyone have any clue concerning what could
> interfere with Struts ?
> Thank you,
> PL
> 2013/1/15 Philippe Lagardere <>:
>> I tried downgrading to, but the exception remains.
>> I also get back my conversion errors on Number/Date fields (I
>> mentionned them in the previous mail), but this was expected, as I did
>> not remove the custom converters I use (see also :
>> ).
>> I haven't tried any older version, because that conversion issue is
>> more critical than the file upload.
>> My first suspect was Struts (probably because I had already met that
>> exception for another Struts-related issue), but it just crossed my
>> mind that the problem could come from something else, namely, the
>> server. I used a Tomcat 6.0.32, more or less free of configuration.
>> I'll dig into this and see if my troubles are server-related. I'll
>> mail back if I find anything.
>> But of course, any insight is more than welcome :)
>> Thanks again,
>> PL
>> 2013/1/14 Lukasz Lenart <>:
>>> Did you try to test with version prior to 2.3.7?
>>> Regards
>>> --
>>> Ɓukasz
>>> + 48 606 323 122

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message