struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Newton <davelnew...@gmail.com>
Subject RE: XML Validation not working
Date Fri, 27 Jul 2012 13:15:39 GMT
Why are you defining an explicit interceptor ref for the action? The
validation interceptor is already in the default stack, and by explicitly
defining an action-specific interceptor you're actually *removing* the
default stack, meaning no parameters will be set on the action, no workflow
takes place, etc.

Dave

(pardon brevity, typos, and top-quoting; on cell)
On Jul 27, 2012 9:11 AM, "Singh, Rajdeep" <rajdeep.singh@hp.com> wrote:

> Thanks for help, I changed it but still getting below error :
>
> Jul 27, 2012 6:36:10 PM
> com.opensymphony.xwork2.util.logging.commons.CommonsLogger error
> SEVERE: Caught exception while loading file
> struts2/application/action/Register-validation.xml
> Connection timed out: connect - [unknown location]
>         at com.opensymphony.xwork2.util.DomHelper.parse(DomHelper.java:115)
>
> My struts.xml file looks like :
>
> <?xml version="1.0" encoding="UTF-8"?>
> <!DOCTYPE struts PUBLIC
>     "-//Apache Software Foundation//DTD Struts Configuration 2.0//EN"
>     "http://struts.apache.org/dtds/struts-2.0.dtd">
> <struts>
> <package name="struts2" extends="struts-default">
>                 <action name="register"
> class="struts2.application.action.Register" >
>                 <interceptor-ref name="validation"/>
>                 <result name="success">/Register.jsp</result>
>                 <result name="input">/LoginForm.jsp</result>
>                 </action>
>                 <action name="validate"
> class="struts2.application.action.RegisterValidate">
>                 <result name="success">/success.jsp</result>
>                 </action>
> </package>
> </struts>
>
> Thanks,
>
> Rajdeep Singh
>
> -----Original Message-----
> From: Łukasz Lenart [mailto:lukasz.lenart@googlemail.com]
> Sent: Friday, July 27, 2012 5:55 PM
> To: Struts Users Mailing List
> Subject: Re: XML Validation not working
>
> Change dtd to:
>
> http://struts.apache.org/dtds/xwork-validator-1.0.2.dtd
>
>
> Regards
> --
> Łukasz
> mobile +48 606 323 122 http://www.lenart.org.pl/
> Warszawa JUG conference - Confitura http://confitura.pl/
>
> 2012/7/27 Singh, Rajdeep <rajdeep.singh@hp.com>:
> > Hi All,
> >
> > I have written classname-validation.xml as per tutorial given at Apache
> site but it's not working for result name "input".
> >
> > Questions :
> >
> > 1. Do I need to write something in struts.xml for default validator to
> work ?
> >
> > Below is my validation xml file :
> >
> > <?xml version="1.0" encoding="UTF-8"?>
> > <!DOCTYPE validators PUBLIC
> > "-//OpenSymphony Group//XWork Validator 1.0.2//EN"
> > "http://www.opensymphony.com/xwork/xwork-validator-1.0.2.dtd">
> > <validators>
> >  <field name="userName">
> >  <field-validator type="requiredstring">
> >         <param name="trim">true</param>
> >         <message>User Name is required</message>
> >         </field-validator>
> >         </field>
> > </validators>
> >
> > Thanks,
> >
> > Rajdeep Singh
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> > For additional commands, e-mail: user-help@struts.apache.org
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message