struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeffrey Benedict <Jeffrey.Bened...@us.usana.com>
Subject Runtime error while starting struts2 application
Date Wed, 27 Jun 2012 16:34:18 GMT
I have followed a struts2 tutorial (http://struts.apache.org/2.0.11/docs/simple-setup.html),
adding minimal jars.  I get the application to start up, but get a runtime exception:

Caught Exception while registering Interceptor class org.apache.struts2.interceptor.validation.AnnotationValidationInterceptor
at com.opensymphony.xwork2.ObjectFactory.buildInterceptor(ObjectFactory.java:214)
                at com.opensymphony.xwork2.config.providers.InterceptorBuilder.constructInterceptorReference(InterceptorBuilder.java:70)
                at com.opensymphony.xwork2.config.providers.XmlConfigurationProvider.lookupInterceptorReference(XmlConfigurationProvider.java:1043)
                at com.opensymphony.xwork2.config.providers.XmlConfigurationProvider.loadInterceptorStack(XmlConfigurationProvider.java:860)
                at com.opensymphony.xwork2.config.providers.XmlConfigurationProvider.loadInterceptorStacks(XmlConfigurationProvider.java:873)
                at com.opensymphony.xwork2.config.providers.XmlConfigurationProvider.loadInterceptors(XmlConfigurationProvider.java:896)
                at com.opensymphony.xwork2.config.providers.XmlConfigurationProvider.addPackage(XmlConfigurationProvider.java:476)
                at com.opensymphony.xwork2.config.providers.XmlConfigurationProvider.loadPackages(XmlConfigurationProvider.java:286)
                at org.apache.struts2.config.StrutsXmlConfigurationProvider.loadPackages(StrutsXmlConfigurationProvider.java:112)
                at com.opensymphony.xwork2.config.impl.DefaultConfiguration.reloadContainer(DefaultConfiguration.java:234)
                at com.opensymphony.xwork2.config.ConfigurationManager.getConfiguration(ConfigurationManager.java:66)


I have researched online about this error.  There isn’t a ton of information on this error,
other than in previous versions of the xwork jar, this bug was introduced.  The bug was supposedly
fixed.  My version of the xwork jar (2.3.4) is way after the version where the supposed fix
was made.  Either the bug was re-introduced, or I am missing something.

Any help would be greatly appreciated.


Thanks
Jeff Benedict



[cid:image1a92e7.JPG@ac3eaae6.42b36188]





This email and any files transmitted with it are confidential and intended solely for the
use of the individual or entity to whom they are addressed. If you have received this email
in error please notify the system manager. Please note that any views or opinions presented
in this email are solely those of the author and do not necessarily represent those of the
company. Finally, the recipient should check this email and any attachments for the presence
of viruses. The company accepts no liability for any damage caused by any virus transmitted
by this email.


Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message