struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maurizio Cucchiara <mcucchi...@apache.org>
Subject Re: Struts2 (caching, valuestack, etc...) problem
Date Mon, 04 Jun 2012 18:42:59 GMT
Are you using spring plugin?
Looks like you are using a previous initialized instance of your action
class.
If yes, ensure that the scope is prototype and not the default one (which
is singletone)

Sent from my mobile device, so please excuse typos and brevity.

Maurizio Cucchiara
Il giorno 04/giu/2012 20.10, "Omar Ngarigari" <ngarigarius@yahoo.com> ha
scritto:

> Hi All,
>
> I have developed an application using struts2.3.1.2, but I
> am experiencing a weird situation that I have bumping my head for a week
> now, but It does not go away.
>
> Scenario 1 - I have a query page (jsp) where I have to query database
> based on the quarter date an input. If I entered a quarter that does not
> have data in the database, I receive an appropriate error message saying
> there is no record found. (That is fine!).
>
> Scenario 2 - On the same query page,  I entered a quarter date that has
> record in the database, then a report is generated. (That is fine!)
>
> Scenario 3 - This is where I am having problem. I click on the back button
> of the IE browser to navigate from the report page back to the query page,
> and at the query page, I entered the same quarter date that I entered at
> the scenario 1, I get the report that was generated on scenario2 rather
> than error message as scenario1.
>
> I have searching all over the place, but not luck. I would appreciate any
> help or clue to the problem.
>
> Thanks,
>
> Omar N.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message