struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From alexcocia <alab...@gmail.com>
Subject [TILES 2.1.2] I18n problem
Date Tue, 19 Jul 2011 13:14:19 GMT
Hi all,
I have an application using Struts2 + Tiles 2.1.2.
The application has some i18n features in two ways: First for text content
depending on the language, secondly for the pages shown, depending on the
language.
For the first option, it is solved using struts "request_locale"
For the second option, the TILES does not change language when modifying the
request locale :o(

I have a tiles.xml configuration file, and the corresponding tiles_en.xml,
tiles_es.xml, tiles_fr.xml....
BUT I found that just the default or English version is working.

Googling I have implemented the LocaleResolver class, defined it in my
application, but when setting another Locale in the resolveLocale method, it
reports "org.apache.tiles.definition.DefinitionsFactoryException: I/O Error
reading definitions."

I guess it tries to get the tiles_es.xml (for instance, when changing to
Spanish), but cannot find it.

Any help? I would really appreciate it.!!!
King regards
Alex



--
View this message in context: http://struts.1045723.n5.nabble.com/TILES-2-1-2-I18n-problem-tp4612299p4612299.html
Sent from the Struts - User mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message