struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Newton <davelnew...@gmail.com>
Subject Re: Action not working - HTTP 500
Date Thu, 26 May 2011 13:38:15 GMT
So you're asking us how to instantiate a class of yours correctly? How would
we know?

Dave
 On May 26, 2011 6:10 AM, "Will Sumekar" <will19790107@gmail.com> wrote:
> I have a service class inside my action class and I override the
constructor
> of my action class adding an instantiation of the service class. If I
remove
> the instantiation, the action will be valid and the page will show
> correctly. There is no error in eclipse.
>
> *
>
> public StifBinConversionAction() {
>
> super();
>
> // svc = new ProcessStifOliBinConversion();
>
> }
> *
>
> How can I instantiate the service object correctly? I do not want to use
> dependency injection like in Spring framework, just want to instantiate
one
> in the action class.
>
> Thanks
> Will
>
>
> On Wed, May 25, 2011 at 4:18 PM, Will Sumekar <will19790107@gmail.com
>wrote:
>
>> Hi
>> I have this action:
>>
>> <action path=*"/view.stif.loader.bin.mapping"*
>>
>> type=*"com.st.mas.wmr.action.StifBinConversionAction"* parameter=*
>> "viewLoaderMapping"*
>>
>> name=*"stifConvForm"* scope=*"request"* validate=*"false"*
>>
>> input=*".editConfig"*>
>>
>> <forward name=*"success"* path=*".viewStifLoadBinMapping"*/>
>>
>> </action>
>>
>> This action used to work, but now it doesn't and I don't know why. I get
"HTTP
>> Status 500 - No action instance for path /view.stif.loader.bin.mapping
could
>> be created". The Action class is still there, and no change is done to
>> struts-config.xml.
>>
>> What other reasons could cause HTTP 500?
>>
>> I'm using Struts 1 with Tiles.
>>
>>
>> Thanks.
>> Will
>>
>>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message