struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kushan Jayathilake <kusha...@gmail.com>
Subject WAR file seems not deployed..
Date Tue, 11 Jan 2011 09:06:19 GMT
Hi Guys,

I have deployed a WAR file in WAS, (It deployed successfully) but when
accessing its URL through the brower it shows this error message

Error 404: SRVE0190E: File not found: /pages/ext/search

This is struts based application and this was working fine sometimes back,
and I have some other application deployed in same WAS, and those are
working fine..

Here is my *web.xml* file contents,

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application
2.3//EN" "http://java.sun.com/dtd/web-app_2_3.dtd">
<web-app>
<display-name>Struts2</display-name>
<welcome-file-list>
<welcome-file>index.jsp</welcome-file>
</welcome-file-list>

<filter>
<filter-name>struts2</filter-name>
<filter-class>
org.apache.struts2.dispatcher.ng.filter.StrutsPrepareAndExecuteFilter
</filter-class>
</filter>

<filter-mapping>
<filter-name>struts2</filter-name>
<url-pattern>/*</url-pattern>
</filter-mapping>

<listener>
<listener-class>com.utc.pw.LogbackShutdown</listener-class>
</listener>

<servlet>
<servlet-name>LogbackInit</servlet-name>
<servlet-class>com.utc.pw.LogbackInit</servlet-class>

<init-param>
<param-name>applicationName</param-name>
<param-value>prdg</param-value>
</init-param>

<init-param>
<param-name>logbackConfigFile</param-name>
<param-value>prdg-config.xml</param-value>
</init-param>

<load-on-startup>1</load-on-startup>
</servlet>

<servlet-mapping>
<servlet-name>LogbackInit</servlet-name>
<url-pattern>/LogbackInit</url-pattern>
</servlet-mapping>


</web-app>



-- 
Regards
Kushan Jayathilake

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message