struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jlm...@gmail.com
Subject Re: Strtus2: httpheader result does not sent headers with hyphenated names
Date Wed, 12 Jan 2011 23:27:40 GMT
No, is that I am subscripted to the list with two accounts. I tried to send the mail with one
of them, but it apparently failed. Then I used the other one, and it worked. A few hours later
the first mail reached the list, that's why it appears twice.
Sent via BlackBerry from T-Mobile

-----Original Message-----
From: Dave Newton <davelnewton@gmail.com>
Date: Wed, 12 Jan 2011 18:09:30 
To: Struts Users Mailing List<user@struts.apache.org>
Reply-To: "Struts Users Mailing List" <user@struts.apache.org>
Subject: Re: Strtus2: httpheader result does not sent headers with hyphenated names

No problem--maybe my email is messed up, because I just got two other posts
about the same topic. Oh well!

Dave

On Wed, Jan 12, 2011 at 6:02 PM, Jose Luis Martinez Avial <
jlmartinez@pb-santander.com> wrote:

> Yes, it worked!!. Thanks.
>
> Jose Luis
>
> -----Original Message-----
> From: Dave Newton [mailto:davelnewton@gmail.com]
> Sent: Wednesday, January 12, 2011 6:00 PM
> To: Struts Users Mailing List
> Subject: Re: Strtus2: httpheader result does not sent headers with
> hyphenated names
>
> Did you try my original answer?!
>
> Dave
>
> On Wed, Jan 12, 2011 at 10:59 AM, Jose Luis Martinez Avial <
> jlmartinez@pb-santander.com> wrote:
>
> > Hi all,
> >
> >    I'm using Struts .2.1.8.1, and I've found a problem when I use
> > result type httpheader and I try to use a header name with a hyphen.
> > They don't get sent. For example, the following result definition:
> >
> > <result name="mvc.security.authentication.ntlm.solicited"
> > type="httpheader">
> >
> >    <param name="status">401</param>
> >
> >    <param name="headers.WWW-Authenticate">NTLM</param>
> >
> >    <param name="headers.a">my header</param>
> >
> >    <param name="headers.WWWAuthenticate">NTLM</param>
> >
> > </result>
> >
> >    I receive the headers "a" and "WWWAuthenticate", but no the header
> > "WWW-Authenticate". Is there any way to fix this behaviour?
> >
> >
> >
> >    Thanks.
> >
> >
> >
> > Jose
> >
> >
> >
> >
> >
> > Internet communications are not secure and therefore Banco Santander
> > International does not accept legal responsibility for the contents of
>
> > this message. Any views or opinions presented are solely those of the
> > author and do not necessarily represent those of Banco Santander
> > International unless otherwise specifically stated.
> >
> > Las comunicaciones via Internet no son seguras y por lo tanto Banco
> > Santander International no asume responsabilidad legal ni de ningun
> > otro tipo por el contenido de este mensaje. Cualquier opinion
> > transmitida pertenece unicamente al autor y no necesariamente
> > representa la opinion del Banco Santander International a no ser que
> > este expresamente detallado.
> >
> >
>
> Internet communications are not secure and therefore Banco
> Santander International does not accept legal responsibility for
> the contents of this message. Any views or opinions presented are
> solely those of the author and do not necessarily represent those
> of Banco Santander International unless otherwise specifically
> stated.
>
> Las comunicaciones via Internet no son seguras y por lo tanto
> Banco Santander International no asume responsabilidad legal ni
> de ningun otro tipo por el contenido de este mensaje. Cualquier
> opinion transmitida pertenece unicamente al autor y no
> necesariamente representa la opinion del Banco Santander
> International a no ser que este expresamente detallado.
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>

Mime
View raw message