struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefaan Somers <stefaan.som...@gmail.com>
Subject Error validating struts-2.0.dtd
Date Tue, 28 Dec 2010 08:22:14 GMT
I have create the most simple struts2 application, where I refer with my
build path to the necessary struts2-jar files.
But it keeps complaining in the Eclipse-IDE on "struts.xml" with the
following message : The errors below were detected when validating the file
"struts-2.0.dtd" via the file "struts.xml". In most cases these errors can
be detected by validating "struts-2.0.dtd" directly. However it is possible
that errors will only occur when struts-2.0.dtd is validated in the context
of struts.xml.

Content struts.xml :
<?xml version="1.0" encoding="UTF-8" ?> <!DOCTYPE struts PUBLIC "-//Apache
Software Foundation//DTD Struts Configuration 2.0//EN" "
http://struts.apache.org/dtds/struts-2.0.dtd"> <struts> <constant
name="struts.enable.DynamicMethodInvocation" value="false" /> <constant
name="struts.devMode" value="false" /> <constant
name="struts.custom.i18n.resources" value="ApplicationResources" /> <package
name="default" extends="struts-default" namespace="/"> <action name="login"
class="net.viralpatel.struts2.LoginAction"> <result
name="success">Welcome.jsp</result> <result name="error">Login.jsp</result>
</action> </package> </struts>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message