struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Lindholm <>
Subject Re: Weird problem with struts tags
Date Fri, 02 Jul 2010 18:46:11 GMT
Your basic problem is that having both getEmployee() and isEmployee()
is a violation of the JavaBeans "standard" so you are asking for
trouble. The Employee property is not a boolean so you really should
rename isEmployee() to something else (maybe isTypeEmployee()).  If
you can't do this then you shouldn't use the OGNL dot style syntax,
instead use explicit java method call style naming like Ken suggested.

WRT the upper vs lower case 'E': The correct use is lowercase 'e'.  I
have heard reports that different versions of OGNL are tolerant of
different cases but you may be causing it to do extra work and slowing
down the evaluation of the expression.  Better to just stick with the
expected leading lowercase letter.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message