struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Burton Rhodes <burtonrho...@gmail.com>
Subject Re: validation and form display problem
Date Sun, 11 Jul 2010 11:23:19 GMT
That sounds like a classic 'prepare' problem.  Take a look at the
documentation on implementing Preparable in your action. You will want
to initialize your backing beans inside the Prepare method in your
action. That when 'input' is needed, your backing beans will be
loaded.

On 7/10/10, Jake Vang <vangjake@googlemail.com> wrote:
> i have a form that i display. but to display that form, i have to
> fetch some data from the database and then place that data on the
> valuestack (via backing beans). when the form is displayed, it expects
> that those backing beans should be populated. the form then posts to a
> save action.
>
> i have a <className>-<alias>-validation.xml that validates the form
> values. i have specified that if the result is "input" then go back to
> the form. the problem is that when the result is "input" and the
> form/page is reloaded, the beans are no longer populated and the form
> displays as blank.
>
> is there a way to intercept or is there a hook that i can grab to have
> an opportunity to populate my backing beans?
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>

-- 
Sent from my mobile device

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message