struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henry Jen <henry...@ztune.net>
Subject Re: Upgrade 2.1.6 to 2.1.8.1, <s:a> cause empty <a /> tag?
Date Wed, 02 Dec 2009 07:40:20 GMT
2009/12/1 Saeed Iqbal <saeedcs@gmail.com>:
> It totally depends on your needs.
>

The only reason we would like to use <s:a> is that we want to use OGNL
in href. For example,

<s:a href="%{#some_var_s:url}">Link</s:a>

If we can use <s:a> would be cleaner. Any suggestion?

Cheers,
Henry

> On Wed, Dec 2, 2009 at 1:14 PM, Henry Jen <henryjen@ztune.net> wrote:
>
>> 2009/12/1 Henry Jen <henryjen@ztune.net>:
>> > Thanks for the prompt reply, but document in 2.1.6 and 2.1.8 doesn't
>> > say that, though It does say it works with simple theme but works best
>> > for ajax.
>> >
>> > 2.1.6 works, so I am wondering if there is a quick way to make it work
>> > for 2.1.8.
>> >
>>
>> Maybe the right approach is simply use <a> rather than <s:a>?
>>
>> Cheers,
>> Henry
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
>> For additional commands, e-mail: user-help@struts.apache.org
>>
>>
>
>
> --
> Saeed Iqbal
> Independant Consultant (Freelance)
> Struts - J2EE - Application Architect / Developer
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message