struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Musachy Barroso <musa...@gmail.com>
Subject Re: Upgrade 2.1.6 to 2.1.8.1
Date Wed, 02 Dec 2009 17:07:19 GMT
make sure you dont have 2 versions of xwork.

musachy

On Wed, Dec 2, 2009 at 8:50 AM, Saeed Iqbal <saeedcs@gmail.com> wrote:
> This looks like a classpath issue
>
> On Wednesday, December 2, 2009, Gustavo Andrés Guevara Saavedra
> <g.guevara@i-deal.hu> wrote:
>> Hi,
>>
>> I've just migrated my app. from Struts 2.1.6 to 2.1.8.1. The application worked fine
but now throws the following exception upon launching the server:
>>
>> Unable to load configuration. - bean - jar:file:/C:/Yazix/workspace/.metadata/.plugins/org.eclipse.wst.server.core/tmp0/wtpwebapps/front_web/WEB-INF/lib/struts2-spring-plugin-2.1.8.1.jar!/struts-plugin.xml:29:132
>>
>> Caused by: java.lang.ClassNotFoundException: com.opensymphony.xwork2.util.classloader.ReloadingClassLoader
>>
>> I've made sure that struts2-core-2.1.8.1.jar as well as struts2-spring-2.1.8.1 are
included and exported to the application, what am I doing wrong?
>>
>> Thanks for the attention,
>>
>> Regards,
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
>> For additional commands, e-mail: user-help@struts.apache.org
>>
>>
>
> --
> Saeed Iqbal
> Independant Consultant (Freelance)
> J2EE - Application Architect / Developer
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message