struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Warsa, Steve" <Steve.Wa...@Avnet.com>
Subject RE: Struts 1.3.8 and WAS 7.0.0.5
Date Thu, 05 Nov 2009 22:48:30 GMT
Now the developer removed all the struts jars except for the Struts 1.3.8 and is getting this
error:

java.lang.ClassNotFoundException: org.apache.struts.taglib.template.PutTag

Here are the jars that are now included in the WAR:

antlr-2.7.2.jar               commons-validator-1.3.1.jar    slf4j-log4j12-1.4.2.jar  struts-core-1.3.8.jar
bsf-2.3.0.jar                 displaytag-1.2.jar             spring-agent.jar         struts-el-1.3.8.jar
commons-beanutils-1.8.0.jar   displaytag-export-poi-1.2.jar  spring-aop.jar           struts-extras-1.3.8.jar
commons-chain-1.2.jar         DisplayTagPatch.jar            spring-beans.jar         struts-faces-1.3.8.jar
commons-codec-1.3.jar         itext-1.3.jar                  spring-context.jar       struts-mailreader-dao-1.3.8.jar
commons-collections-3.2.jar   jcl104-over-slf4j-1.4.2.jar    spring-core.jar          struts-scripting-1.3.8.jar
commons-digester-1.8.jar      jstl-1.1.2.jar                 spring-dao.jar           struts-taglib-1.3.8.jar
commons-fileupload-1.1.1.jar  log4j-1.2.15.jar               spring.jar               struts-tiles-1.3.8.jar
commons-io-1.1.jar            oro-2.0.8.jar                  spring-jdbc.jar
commons-lang-2.3.jar          poi-3.2-FINAL.jar              spring-jdo.jar
commons-logging-1.1.1.jar     slf4j-api-1.4.2.jar            standard-1.0.6.jar

Thanks,
Steve Warsa
Avnet GIS
work: 480-794-7920
cell: 602-692-1562
 
"Everything should be made as simple as possible ...but no simpler."

--Albert Einstein


-----Original Message-----
From: Warsa, Steve [mailto:Steve.Warsa@Avnet.com] 
Sent: Thursday, November 05, 2009 2:06 PM
To: 'user@struts.apache.org'
Subject: Struts 1.3.8 and WAS 7.0.0.5

Hi All,

I am a WAS admin and I have a developer who migrated his EAR to JEE 5 and servlet 2.5.  His
EAR uses Struts 1.3.8  Apparently, it works fine (without error) running on his local environment
(RAD 7.5) on the WAS 7.0.0.3 embedded test environment.  However, when deploying to WAS 7.0.0.5
(our Linux based WAS ND environment), he gets this error when hitting the first page:


[11/5/09 11:26:36:825 MST] 00000024 servlet E com.ibm.ws.webcontainer.servlet.ServletWrapper
service SRVE0068E: Uncaught exception created in one of the service methods of the servlet
/jsp/Login.jsp in application aats. Exception created : com.ibm.websphere.servlet.error.ServletErrorReport:
java.lang.NoSuchMethodError: org/apache/struts/util/RequestUtils.message&#40;Ljavax/servlet/jsp/PageContext&#59;Ljava/lang/String&#59;Ljava/lang/String&#59;Ljava/lang/String&#59;[Ljava/lang/Object&#59;&#41;Ljava/lang/String&#59;
at org.apache.jasper.runtime.PageContextImpl.handlePageException(PageContextImpl.java:695)
at com.ibm._jsp._Login._jspService(_Login.java:209)
at com.ibm.ws.jsp.runtime.HttpJspBase.service(HttpJspBase.java:98)

Any ideas?  Is struts 1.3.8 compatible with WAS 7.0.0.5?  Here is a list of jars he has in
his WEB-INF/lib under the WAR:

antlr-2.7.2.jar
bsf-2.3.0.jar
commons-beanutils-1.7.0.jar
commons-beanutils-1.8.0.jar
commons-chain-1.1.jar
commons-chain-1.2.jar
commons-codec-1.3.jar
commons-collections-3.1.jar
commons-collections-3.2.jar
commons-digester-1.8.jar
commons-fileupload-1.1.1.jar
commons-io-1.1.jar
commons-lang-2.3.jar
commons-logging-1.0.4.jar
commons-logging-1.1.1.jar
commons-validator-1.3.1.jar
displaytag-1.2.jar
displaytag-export-poi-1.2.jar
DisplayTagPatch.jar
itext-1.3.jar
jcl104-over-slf4j-1.4.2.jar
jstl-1.0.2.jar
jstl-1.1.2.jar
log4j-1.2.13.jar
log4j-1.2.15.jar
oro-2.0.8.jar
poi-3.2-FINAL.jar
slf4j-api-1.4.2.jar
slf4j-log4j12-1.4.2.jar
spring-agent.jar
spring-aop.jar
spring-beans.jar
spring-context.jar
spring-core.jar
spring-dao.jar
spring-hibernate3.jar
spring-ibatis.jar
spring.jar
spring-jdbc.jar
spring-jdo.jar
standard-1.0.2.jar
standard-1.0.6.jar
struts-core-1.3.10.jar
struts-core-1.3.8.jar
struts-el-1.3.10.jar
struts-el-1.3.8.jar
struts-extras-1.3.10.jar
struts-extras-1.3.8.jar
struts-faces-1.3.10.jar
struts-faces-1.3.8.jar
struts.jar
struts-mailreader-dao-1.3.10.jar
struts-mailreader-dao-1.3.8.jar
struts-scripting-1.3.10.jar
struts-scripting-1.3.8.jar
struts-taglib-1.3.10.jar
struts-taglib-1.3.8.jar
struts-tiles-1.3.10.jar
struts-tiles-1.3.8.jar

I know he has 2 versions of several jars, but he said this:

"It is expected to use Struts 1.3.8. But WAS looks for some API which is only available in
Struts 1.1. So, I added Struts 1.1 to application classpath to remove the error caused by
some classes in WAS."

So, it sounds like he was having problems with 1.3.8 and WAS 7.0.0.3 initially.  Does anyone
know if they are compatible?

Thanks,
Steve


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message