struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From KamHon Eng <kam...@gmail.com>
Subject Re: Where does Struts looks for Validation xml file?
Date Wed, 25 Nov 2009 03:30:04 GMT
during redeploy, do you clean up compiled folder(classes folder)? I
believe the SubmitUserAction-validation.xml still there.

On Wed, Nov 25, 2009 at 2:22 AM, james billa <jambilla@gmail.com> wrote:
> I have a JSP page with two fields user name, college name and a submit
> button.  I have a xml validation file SubmitUserAction-validation.xml to
> validate both the fields on the screen. The action is mapped to
> SubmitUserAction. On clicking the submit button it gets executed executed
> successfully and is doing what it is supposed to do. If the fields are
> empty, the validation is getting fired.  So far every thing works fine.
>
> Now the problem comes.. I decided not to have the validation anymore. So I
> deleted my validation xml file and also
> in my struts.xml file, in the action mapping I have removed the <result
> name="input" .... >  entry that i added earlier for
> validation. So now it looks simple as shown below.
>
>        <action name="UpdateUserChange" class="com.jj.SubmitUserAction">
>            <interceptor-ref name="myUserStack" />
>            <result name="success" type="redirect">DisplayUsesr</result>
>        </action>
>
> I cleaned my server, deployed the app again and restarted the server. But
> now the app is not working any more on
> submitting the form. It goes to validation method in my action class and
> then it fails.
>
> Then I renamed the action class to something else and it worked fine.
>
> So I wondering is still struts looking for my validation.xml file? Before
> introducing the validation it worked fine,
> after introducing the validation file it worked fine. But on deleting the
> validation file, it is still looking for
> it? why is it so? Or I am missing something? I am using struts 2.1.6,
> eclipse.
>
> Please ignore any upper/lower case issue or spelling issue in the above
> code. It is not the exact one that I am
> using. Thank you.
>



-- 
Best Regard,

Kam Hon

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message