struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From holod <serega.shey...@gmail.com>
Subject proxy server corrupts json encoding
Date Sat, 14 Nov 2009 11:46:38 GMT

Hi, please, help me to find a solution.
I'm using json plugin. The base of my app is IBM WebSphere Portal Server
6.1, I'm writing portlets.

This is xml configuration for action
[code]
<action name="refreshProductList" class="MyClass">
	    	<interceptor-ref name="portletResponse">
				application/json;charset=UTF-8
			</interceptor-ref>
			<interceptor-ref name="portletDefaultStack" />
            <interceptor-ref name="json"/>
            <result name="success" type="json">
           		UTF-8
        		true<!-- "false" corrupts encoding even in NON proxy mode -->
        		application/json
            </result>              
        </action>
[/code]

The problem is:
When I'm invoking action directly, everything is OK. When Portal server is
hidden behind proxy-server, json data is corrupted. I get bad characters in
string instead of normal data. I'm using russian chars. They become
corrupted.
What do I have to do? 

-- 
View this message in context: http://old.nabble.com/proxy-server-corrupts-json-encoding-tp26349347p26349347.html
Sent from the Struts - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message