struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cpanon <cpa...@yahoo.com>
Subject Struts 1.3.10 problem
Date Mon, 26 Oct 2009 01:00:10 GMT
Hello
I have a page that has two active portions, "feed" by session objects
and iterated. It works fine monolithically. I now want to break it up
into a frameset using the struts frame tag for the individual segmented
portions. Before I launch to my frameset composed page, I land on a
page that confirms that the two segments work, with an strut html:link.
It also works, properly formatted with a sessionsID, and when click the
page (either) correctly loads. When I jump to my frameset composed page
it does not load, does not have the sessionID(reason it doesnt load),
but no errors on compiler error. In the example below I show it with a
forward, but it is the same/failure with either a properly defined
forward or a simple page attribute. Any ideas? If I use Tiles will it
not force a reload in one tile when another is submitted and posted
back?

the crucial segment on the composed page is: 
<html:link  page="/inner.jsp" title="innerFrame">InnerFrame</html:link> 
<html:link  page="/static.jsp" title="staticFrame">staticFrame</html:link> 
<frameset rows="85%,15%" id="enclosingFrame" title="totalFrame"> 
<html:frame forward="innerFrame" frameName="inner" styleId="innerFrame" marginwidth="0"/>

<html:frame forward="staticFrame" frameName="static" styleId="staticFrame" marginwidth="0"/>

</frameset>
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message