struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jcllings <jlistn...@gmail.com>
Subject Re: Problem with result returning from interceptor
Date Fri, 11 Sep 2009 11:53:35 GMT


jcllings wrote:
> 
> OK, I was able to get the config-browser to display the result. Is it OK
> to use chain, as I have below?  All I'm really trying to do is force the
> user to a specific page but I have to call an action to populate tables
> and list boxes and stuff on that page. 
> 
>         <global-results>
>             <result type="chain"
> name="login">/admin/funkycool.action</result>
>         </global-results>
> 
> 

I have some new and interesting behavior to report. Now that I have a global
result that shows up in the config browser, I can clear out my cookies and
perform an action using the config browser and the behavior is as expected.
I get routed to the /admin/funkycool.action which then sets up my page and
loads it. 

Problem is that it doesn't work if I try it from the web.  I should be able
to clear out the cookies and click on a link to an action in the page and it
would do the same thing, right?  This is not the case.  Any ideas?
-- 
View this message in context: http://www.nabble.com/Problem-with-result-returning-from-interceptor-tp25075486p25399579.html
Sent from the Struts - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message