struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Gainty <mgai...@hotmail.com>
Subject RE: JSP not loading
Date Mon, 10 Aug 2009 13:19:39 GMT

JSPs are 'precompiled' by container to 
$TOMCAT_HOME/work/Catalina/localhost/webappName folder

if your FileSystem is not setup to accomodate chinese characters
any chinese characters that your filesystem sees
will not produce the desired UnknownChineseCharacters_jsp.java
so container will be unable to serve that file

try a localhost reference on the AppServer via
http://localhost:Port/webappName/NameOfChineseJsp.jsp
and notice the failure..

Martin Gainty 
______________________________________________ 
Verzicht und Vertraulichkeitanmerkung/Note de déni et de confidentialité
 
Diese Nachricht ist vertraulich. Sollten Sie nicht der vorgesehene Empfaenger sein, so bitten
wir hoeflich um eine Mitteilung. Jede unbefugte Weiterleitung oder Fertigung einer Kopie ist
unzulaessig. Diese Nachricht dient lediglich dem Austausch von Informationen und entfaltet
keine rechtliche Bindungswirkung. Aufgrund der leichten Manipulierbarkeit von E-Mails koennen
wir keine Haftung fuer den Inhalt uebernehmen.
Ce message est confidentiel et peut être privilégié. Si vous n'êtes pas le destinataire
prévu, nous te demandons avec bonté que pour satisfaire informez l'expéditeur. N'importe
quelle diffusion non autorisée ou la copie de ceci est interdite. Ce message sert à l'information
seulement et n'aura pas n'importe quel effet légalement obligatoire. Étant donné que les
email peuvent facilement être sujets à la manipulation, nous ne pouvons accepter aucune
responsabilité pour le contenu fourni.




> Date: Mon, 10 Aug 2009 14:53:46 +0200
> From: eduard.neuwirt@googlemail.com
> To: user@struts.apache.org
> Subject: Re: JSP not loading
> 
> Hi,
> are you sure that the answer is sent to the correct JSP. Please check 
> your struts.xml for the action and make sure that the correct result is 
> chosen. In case of Chinese and if you are using the dynamic method 
> invocation the result may be incorrect.
> 
> Regards
> Eduard
> 
> 
> Kavita Mehta schrieb:
> > Hi ,
> > I am facing a strange problem. I am using struts2.0 and my server side 
> > code executes well and sends the response ..but my ethereal shows empty 
> > response and hence my JSPs are not loading on the browser .
> > This happens when user has mentioned his details in lets say chinese 
> > language . i.e. any character other than english doesnt get interpreted by 
> > my JSP code. 
> >
> > Can anyone pls help ?
> >
> >
> > Thanks,
> > Kavita
> >
> >
> >
> >
> > *****************************************************DISCLAIMER*****************************************************
> >
> > This message and/or attachment(s) contained here are confidential, proprietary to
HUGHES SYSTIQUE and its customers. 
> > Contents may be privileged or otherwise protected by law. The information is solely
intended for the entity it is 
> > addressed to. If you are not the intended recipient of this message, it is strictly
prohibited to read, forward, 
> > print, retain, copy or disseminate this message or any part of it. If you have received
this e-mail in error, 
> > please notify the sender immediately and delete the message.
> >
> > ********************************************************************************************************************
> >
> >
> >   
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
> 

_________________________________________________________________
Get back to school stuff for them and cashback for you.
http://www.bing.com/cashback?form=MSHYCB&publ=WLHMTAG&crea=TEXT_MSHYCB_BackToSchool_Cashback_BTSCashback_1x1
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message