struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Newton <newton.d...@yahoo.com>
Subject Re: Struts 2.1.6 TLD file
Date Thu, 30 Jul 2009 20:17:05 GMT
Dan Slack wrote:
> Our J2EE server (Sybase EAServer 6.1) has been complaining about my struts 2
> application when I deploy it.  After some digging, it turns out that the
> "tlibversion" in the Struts2 tld file is "invalid".  This seemed to happen
> when I changed my project to Servlet 2.5.  
> 
> The Struts 2 tlibversion is 2.2.3, and I know that the 'tlibversion' can be
> a dewey-decimal type, but from my memories of libraries, I don't remember it
> being allowed to have 2 decimal points.  Does anybody know if this is a
> failing of my server, or is this something that is a failing of Struts2?

I don't know what it's supposed to be, but at least some taglib DTD's 
([1] for example) contain the following:

<!ELEMENT tlib-version (#PCDATA) >

<!--
Describes the JSP version (number) this taglibrary requires in
order to function (dewey decimal)

The default is 1.2

#PCDATA ::= [0-9]*{ "."[0-9] }0..3
-->

Dave

[1] Note also that Sun's 1.2 DTD contained the same:
http://svn.apache.org/repos/asf/tomcat/servletapi/branches/other/servlet2.4-jsp2.0-tc5.x/js5/src/share/dtd/web-jsptaglibrary_2_0.dtd

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message