struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Kiley <jhki...@summa-tech.com>
Subject Re: dojo ajax tags -- post vs. get
Date Tue, 07 Jul 2009 20:42:01 GMT
It turns out that the problem was solved by removing nesting form tags.  I
hadn't noticed, originally, that the "familySelection" form described below
was wrapped by another form tag.  When I unwrapped it, everything worked
correctly.  Let this be a lesson to you. Somebody.
jk

On Tue, Jul 7, 2009 at 3:36 PM, Jim Kiley <jhkiley@summa-tech.com> wrote:

> Hi gang,
> We are taking our first steps into using the dojo tags, in a Struts 2.1.7
> project (yes, we jumped too soon, I don't think it's entirely relevant).
>  Specifically I've got an <s:select> tag set up, and when its value changes,
> I publish a dojo event ("/changeFamily").  A div is set up with <sx:div> as
> follows:
>
> <s:form id="familySelection">
>   <s:select name="familyId" listKey="id" listValue="name" headerKey="0"
> headerValue="Select One" list="familyList"
> onchange="dojo.event.topic.publish('/changeFamily');" />
> </s:form>
>
> <s:url id="catalogContentsUrl" action="catalog-contents"/>
> <sx:div formId="familySelection" indicator="bigRotationImage"
> href="%{catalogContentsUrl}" listenTopics="/changeFamily">
>   (No family selected)
> </sx:div>
>
> When I change a value in the s:select, however, Firebug tells me that the
> page is executing a GET rather than a POST.  So the value of familyId never
> gets posted (breakpoints indicate that the setter does not run).
>
> What do I have to do in order to get the value of familyId to be posted?
> --
> Jim Kiley
> Senior Technical Consultant | Summa
> [p] 412.258.3346
> http://www.summa-tech.com
>



-- 
Jim Kiley
Senior Technical Consultant | Summa
[p] 412.258.3346
http://www.summa-tech.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message