struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Luis Esquivel" <LEsqui...@copera.org>
Subject RE: Struts 1.3.10 problem
Date Mon, 22 Jun 2009 13:56:45 GMT
Hello Thank you for your response!  
Yes Actually I made a mistake on my email.  We were using 1.2 prior.
We went through the link you sent me here and followed it to the letter.

What we are hopping is that somebody might have come across this type or problems that might
be able to help us.

Please let me know if you have any other suggestion.

Thanks!

-----Original Message-----
From: Girish Naik [mailto:girish.naik@gmail.com] 
Sent: Friday, June 19, 2009 10:13 PM
To: Struts Users Mailing List
Subject: Re: Struts 1.3.10 problem

May be this will bring some help:
http://wiki.apache.org/struts/StrutsUpgradeNotes12to13

But what i feel is that the app should have been upgraded to 1.2 first then
from there to 1.3 ?

Regards,
---------------------------------------------------------
Girish Naik
Mobile:-+91-09740091638
girish.naik@gmail.com
George Carlin<http://www.brainyquote.com/quotes/authors/g/george_carlin.html>
- "Electricity is really just organized lightning."

On Sat, Jun 20, 2009 at 2:59 AM, Luis Esquivel <LEsquivel@copera.org> wrote:

> Hello,
>
> We are seeing a problem with this version of struts that we haven't been
> able to resolve.  I hope somebody can help.
> We had an old app in struts 1.1.X and decided to upgrade to 1.3.10.
> The application that has been working for quite a few years stopped
> working after doing the upgrade.
>
> Here is what happens:
> I have an action declaration as such -
>
>    <action-mappings>
>        <action path="/AForm"
>                type="com.package.AClassAction"
>                name="aForm"
>                scope="session"
>                input="/AForm.jsp"
>                validate="true">
>            <forward name="success" path="/AForm.jsp"/>
>        </action>
>    </action-mappings>
>
> When the action gets called, I get a blank page.  The only way this
> works is if I add the "redirect=true" attribute to the <forward> tag.
> The .jsp file in this case AForm.jsp does get called as I can see the
> logging I added to see if it was even hitting that .jsp.  We need it to
> work without having to specify the redirect=true attribute.
>
> I have run the examples that are packaged in the struts 1.3.10
> distribution and they all run fine on our server configuration.
>
> Does anyone have any idea as to what could be causing this error?  If I
> switch jar files and change the dtd's to the older struts, the
> application works ok.
>
> Any help would be greatly appreciated.   Let me know if you need more
> information than what I have given in this email.
>
> Thanks!
>
>
> Luis Esquivel
> Application Development
> Public Employees' Retirement Assoc. of Colorado
> 1300 Logan Street
> Denver, CO 80203
> 303 - 837 - 6296
>
>
Mime
View raw message