struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Luis Esquivel" <LEsqui...@copera.org>
Subject Blank Page in 1.3.10
Date Mon, 22 Jun 2009 13:47:53 GMT
Hello,  

We are seeing a problem with this version of struts that we haven't been
able to resolve.  I hope somebody can help.
We had an old app in struts 1.1.X and decided to upgrade to 1.3.10.
The application that has been working for quite a few years stopped
working after doing the upgrade. 

Here is what happens:
I have an action declaration as such - 

    <action-mappings>
        <action path="/AForm"
                type="com.package.AClassAction"
                name="aForm"
                scope="session"
                input="/AForm.jsp"
                validate="true">
            <forward name="success" path="/AForm.jsp"/>
        </action>
    </action-mappings>

When the action gets called, I get a blank page.  The only way this
works is if I add the "redirect=true" attribute to the <forward> tag.
The .jsp file in this case AForm.jsp does get called as I can see the
logging I added to see if it was even hitting that .jsp.  We need it to
work without having to specify the redirect=true attribute.

I have run the examples that are packaged in the struts 1.3.10
distribution and they all run fine on our server configuration.

Does anyone have any idea as to what could be causing this error?  If I
switch jar files and change the dtd's to the older struts, the
application works ok.

Any help would be greatly appreciated.   Let me know if you need more
information than what I have given in this email.

Thanks!

Luis Esquivel


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message