struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wes Wannemacher <w...@wantii.com>
Subject Re: Interceptor Trouble
Date Wed, 27 May 2009 16:47:48 GMT
On Wed, May 27, 2009 at 8:18 AM, Jim Collings <jlistnews@gmail.com> wrote:
[snip]
>
> Here is the relevant portion of the xml:
>
> <package name="xxx" extends="struts-default">
>        <interceptors>
>            <interceptor name="UidIntercept"
> class="com.eds.xxx.web.admin.UidInterceptor"/>
>            <interceptor-stack name="CustomStack">
>                <interceptor-ref name="paramsPrepareParamsStack"/>
>                <interceptor-ref name="UidIntercept"/>
>            </interceptor-stack>
>        </interceptors>
>        <default-interceptor-ref name="CustomStack"/>
>    </package>
>
> Clues anyone?  I can see the init() being called in the logs but I
> never see intercept.
>

Do you have any actions in that package? Your interceptor should be
run, but only against actions in that package (xxx). Also, your
interceptor is last in your stack, so things like validation failure
can keep it from firing.

-Wes


-- 
Wes Wannemacher
Author - Struts 2 In Practice
Includes coverage of Struts 2.1, Spring, JPA, JQuery, Sitemesh and more
http://www.manning.com/wannemacher

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message