struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Musachy Barroso <musa...@gmail.com>
Subject Re: Struts 2 integration with classic struts 1
Date Wed, 11 Feb 2009 18:55:01 GMT
You don't need to add that parameter if you are not using the
Codebehind plugin annotations.

musachy

On Wed, Feb 11, 2009 at 12:41 PM, SanJ.SANJAY <girish.sh@gmail.com> wrote:
>
> Well,  it was asking for the action parameters to put in web.xml , I did that
> and it worked.
> <filter>
>                <filter-name>struts2</filter-name>
>                <filter-class>
>                        org.apache.struts2.dispatcher.FilterDispatcher
>                </filter-class>
>                <init-param>
>                <param-name>actionPackages</param-name>
>                <param-value>user.actions</param-value>
>               </init-param>
>                </filter>
>        <filter-mapping>
>                <filter-name>struts2</filter-name>
>                        <url-pattern>/*</url-pattern>
>        </filter-mapping>
>
> as far as I could understand this parameters is needed if I am using some
> annotation but I do not think I currently have any annotation in the code
> then why I do have to put this action[ackes stuff with a dummy value to
> <param-value>user.actions</param-value> ????
>
>
>
>
>
> SanJ.SANJAY wrote:
>>
>> Thanks Dave, that helped. I'm getting a completely weird error message now
>>
>> java.lang.RuntimeException: java.lang.RuntimeException:
>> com.opensymphony.xwork2.inject.DependencyException:
>> com.opensymphony.xwork2.inject.ContainerImpl$MissingDependencyException:
>> No mapping found for dependency [type=java.lang.String,
>> name='actionPackages'] in public void
>> org.apache.struts2.config.ClasspathPackageProvider.setActionPackages(java.lang.String).
>>
>> Any idea why this could've break?? I am clueless about thsi error.
>>
>>
>>
>>
>> newton.dave wrote:
>>>
>>> SanJ.SANJAY wrote:
>>>> Why would the basic integration ask for a plexus listener to be put in
>>>> web.xml? And by the way do we really need plexus integration when my
>>>> concern
>>>> is nly to upgrade from struts 1-2?
>>>
>>> If you're using the Plexus plugin, then you need whatever else Plexus
>>> requires. I'm guessing you have the plexus-plugin jar file--just remove
>>> it (although IIRC you'll still need commons-io and commons-fileupload).
>>>
>>> Dave
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
>>> For additional commands, e-mail: user-help@struts.apache.org
>>>
>>>
>>>
>>
>>
>
> --
> View this message in context: http://www.nabble.com/Struts-2-integration-with-classic-struts-1-tp21943166p21958285.html
> Sent from the Struts - User mailing list archive at Nabble.com.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>



-- 
"Hey you! Would you help me to carry the stone?" Pink Floyd

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message