struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From vol...@magiccode.eu
Subject RE: Struts2 2.0.11 problem with url and parameters
Date Wed, 19 Nov 2008 15:19:27 GMT
Hi,

what does your parameter look like ?
Is it ?parameter=value   ??

Try using 
 <s:url action="editGadget">
     <s:param name="id" value="%{selected}" />
 </s:url>
where name is the name of your setter-method. (In this case setId)

Regards

  Volker




Hi all,

I have a url with a parameter. This parameter is sent to the action via HTTP
Get Method(i.e appended at the end of the url --> ?parameter_value). My
problem is that I can't reach the parameter value in the action because the
setter method is not being called. I can't get the value throught 

'ActionContext.getContext().getParameters();' neither.

This is my code. What I'm doing wrong?.

<str:url id="url_delete" action="EliminarSuscripcion">
    <str:param name="indice" value="%{#stat.index}"></str:param>
</str:url>
<str:a href="%{url_delete}">Eliminar</str:a>

Thanks in advance.
-- 
View this message in context: 
http://www.nabble.com/Struts2-2.0.11-problem-with-url-and-parameters-tp20577582p
20577582.html
Sent from the Struts - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message