struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Moose" <jgmo...@gmail.com>
Subject There is no Action mapped for namespace / and action name ...
Date Mon, 28 Jul 2008 19:58:21 GMT
I know what you're thinking... web.xml has no action mapping, but it does!


<?xml version="1.0" encoding="UTF-8"?>
<web-app version="2.5"
    xmlns="http://java.sun.com/xml/ns/javaee"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://java.sun.com/xml/ns/javaee
    http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd">

    <display-name>Struts 2 RESTful Ozone Services</display-name>

  <!-- Filters -->
      <filter>
          <filter-name>action2</filter-name>

<filter-class>org.apache.struts2.dispatcher.FilterDispatcher</filter-class>
          <init-param>
              <param-name>actionPackages</param-name>
              <param-value>com.myeclipse.ozone</param-value>
          </init-param>
          <init-param>
              <param-name>struts.devMode</param-name>
              <param-value>true</param-value>
          </init-param>
      </filter>

      <filter-mapping>
          <filter-name>action2</filter-name>
          <url-pattern>/*</url-pattern>
      </filter-mapping>

  <welcome-file-list>
    <welcome-file>index.jsp</welcome-file>
  </welcome-file-list>
</web-app>



This file works well with another Struts2.1.3 app.  Can someone help me
understand where to look for the cause of this???

Thanks folks

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message