struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Lester" <Ma...@housing.ufl.edu>
Subject RE: Action-Redirect Parameter Problem
Date Mon, 02 Jun 2008 12:08:42 GMT
Yeah I am still having problems with it.

-----Original Message-----
From: Adam Hardy [mailto:ahardy.struts@cyberspaceroad.com] 
Sent: Sunday, June 01, 2008 2:52 PM
To: Struts Users Mailing List
Subject: Re: Action-Redirect Parameter Problem

That issue is closed, although there is a comment left after it was
closed 
suggesting that the issue is still a problem and that the bug should
be re-opened.

I see this 'warning' from OGNL wherever I use Action-Redirect results
with the 
latest struts2 version, and it's true that the stacktrace in the
webserver log 
is distracting, but I don't find any problems with it like the last
comment 
suggests.

It's not clear why the poster of that comment didn't re-open the bug
or create a 
new one if there is a real problem there.

Do you find problems with it still?

It seems to me that the issue should not have been changed from status
open to 
resolved, rather it should have been changed from priority major to
enhancement.

Also the poster of the last comment should have left more details with
perhaps a 
patch or unit-test displaying his/her bug.


Adam


Mark Lester on 30/05/08 14:31, wrote:
> Thanks for the quick response. I don't think that is the problem
> because that directory is already clear plus I have only used the
> current version of struts2
>  
> -----Original Message-----
> From: Owen Berry [mailto:owen.berry@gmail.com] 
> Sent: Friday, May 30, 2008 9:24 AM
> To: Struts Users Mailing List
> Subject: Re: Action-Redirect Parameter Problem
> 
> If you're using Maven, you should try clearing out your local Maven
> repository (rm -rf ~/.m2/repository) and try again ... I've had a
few
> cases where I seemed to be using old versions of jars until I did
> this.
> 
> On Fri, May 30, 2008 at 9:18 AM, Mark Lester <MarkL@housing.ufl.edu>
> wrote:
>> I followed the
>> http://struts.apache.org/2.x/docs/redirect-action-result.html To
> pass
>> parameters to an action
>>
>> And it generates the exception
>>
>> Caught OgnlException while setting property 'navigation' on type
>> 'org.apache.struts2.dispatcher.ServletActionRedirectResult'.
>>
>>
>>
>> I looked the Exception up and I found a bug report for struts 2 at
>>
>> http://issues.apache.org/struts/browse/WW-1714
>>
>>
>>
>> The problem is that it says the issue is resolved as of version
2.08
>> but I am using 2.11 and I am still getting the warning.
>>
>> Information regarding this issue would be very helpful.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org

Mime
View raw message