struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Márcio Gurgel" <marcio....@gmail.com>
Subject Re: Struts 2 + Hibernate question
Date Fri, 30 May 2008 03:08:34 GMT
Hi,

Tanks for your response.
I used to run it on Mozilla, now I tryied in IE 7 but the problem persists.
By debug I saw that the object is coming with the old state.

Sorry about writing "cash"... I also have to improve my english.

Regards!

Márcio Gurgel

2008/5/29 Al Sutton <al.sutton@alsutton.com>:

> Are you sure the page isn't being cached by your browser? Try hitting
> reload (or CTRL + Reload if you're using IE).
>
> Al.
>
>
> Márcio Gurgel wrote:
>
>> Hi all!
>>
>> I'm using struts 2 + hibernate.
>> I've a strange problem, if someone could give me a hand I'll be so
>> tankfull.
>>
>> If I persist a object in my app every things go well and all relationchips
>> are stored correctey correctly.
>> The problem occours when I update this object... After the update all data
>> are stored correctly too, but the problem is that my page shows the old
>> object (different from database).
>>
>> This could be some kind of cash from struts 2? Or my problem is just
>> hibernate?
>>
>> I tryed this methods to force a refresh after bring the object from
>> database
>> session.refresh(obj)
>> session.flush()
>>
>> Tank so much for attention!
>>
>> Márcio Gurgel
>>
>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message