struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc Ende <mli...@e-beyond.de>
Subject Re: Url-Parameters only set once
Date Sun, 06 Apr 2008 19:18:43 GMT
Hello Dave,

I've found a solution for that. The spring-action was standard-scoped 
and in cause of that it didn't accept the
id parameter a second time.

I think it's a little bit strange that it's impossible to set an 
property again when it's done before.

Marc




Dave Newton schrieb:
> --- Marc Ende <mlists@e-beyond.de> wrote:
>   
>> I've got a list with several items which are linked to a details-action.
>> If I klick on an item after the restart of the webapp a link like
>> http://.../details.action?id=123
>> is called. Everything is fine. I can see the correct details site.
>> When I go back and klick on another item (with another id)
>> the old id is called from the database and shown.
>>     
>
> Without any further info it's hard to say what the problem might be.
>
> Actions are instantiated per-request, unless you've mis-configured a
> Spring-defined action.
>
> Depending on how you're creating the links (and how your application is laid
> out) you may be getting URL parameters you're not expecting in your link;
> <s:url...> has an "includeParams" attribute you might want to look at.
>
> I'm sure there are more possibilities, but we might need more info in order
> to help.
>
> Dave
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>   


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message