struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mojoRising <jpi...@averoinc.com>
Subject Re: execAndWait losing form parameters
Date Fri, 25 Apr 2008 15:06:51 GMT

Could this be related to the meta refresh tag on the wait page? I saw 2
examples on how to structure this tag:

from: http://struts.apache.org/2.x/docs/execute-and-wait-interceptor.html
<meta http-equiv="refresh" content="5;url=<s:url includeParams="all" />"/>

And from the manning book:
<meta http-equiv="refresh" content="2;url=<s:url/>"/>


When I add the 'includeParams="all"' it doesn't seem to work at all, that
is, the parameters that are being passed in to the action are getting lost,
so I have not been using the latter example; which also does not work; when
i submit a user profile form the request parameters get lost.

Does anyone know what could be the issue here?



mojoRising wrote:
> 
> I have a form that updates a user profile. When I add the 'execAndWait'
> Interceptor it appears to work correctly - that is, the wait.jsp page
> displays and then goes back to the results page. But, the request
> parameters (those from the user profile form that are being submitted) are
> getting lost. Am I missing something?
> 

-- 
View this message in context: http://www.nabble.com/execAndWait-losing-form-parameters-tp16851913p16895869.html
Sent from the Struts - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message