struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Newton <newton.d...@yahoo.com>
Subject Re: Struts2 validation issue when internet is not available in the application server.
Date Wed, 26 Mar 2008 14:18:23 GMT
--- Dave Newton <newton.dave@yahoo.com> wrote:
> --- Nuwan Chandrasoma <mymailnot@gmail.com> wrote:
> > This is my xml file. when we run in a local machine that has internet 
> > access this works fine.
> > 
> > <?xml version="1.0" encoding="UTF-8"?>
> > <!DOCTYPE validators PUBLIC
> >           "-//OpenSymphony Group//XWork Validator 1.0.2//EN"
> >           "http://www.opensymphony.com/xwork/xwork-validator-1.0.2.dtd">
> 
> Hmm, AFAICT that's exactly what I'm using.
> 
> What container are you running in? I'm running via a local Tomcat via
> Eclipse Europa; it's possible that Eclipse has cached my DTD or 
> something. I'll look in to it a bit more.

Just as a quick followup, with no internet access and no DTD caching it still
seems to work okay.

It's also giving me confusing log entries; I have no annotations in my action
class that's being validated, but the debugs are from the annotation
validation manager. The messages being displayed are from the XML file. So
I'm a little lost and potentially less useful than I thought ;)

Dave


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message