struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Newton <newton.d...@yahoo.com>
Subject RE: Simple helloworld test fails with "Could not find action orresult"
Date Thu, 06 Mar 2008 16:06:04 GMT
--- "Karr, David" <david.karr@wamu.net> wrote:
> > So is the "package" attribute supposed to match the Java 
> > package of the Action classes?  Martin Gainty had earlier 
> > said I should use actionPackages.  Before I added that, it 
> > wasn't even getting into my Action classes at all.  If I now 
> > remove actionPackages, change the package attribute to match 
> > my Java class, and then remove the namespace attribute, do 
> > you expect that will work?
> 
> I can self-answer this, I guess.  After removing actionPackages, and
> setting the "package" attribute to match the Java class (something I can
> easily see someone assuming) makes it say this (it's even bad grammar,
> besides being a broken message):

What "package" attribute? In the struts config file? I'll look in to that. I
don't think the documentation states anything in particular about naming
requirements for packages; if there is one we'll document it.

> Are there still any issues hiding here that I should know about?

I'm not sure how we'd know if there were or not. This is the first time,
AFAIK, that these issues have come up at all. You tried to mix two forms of
configuration; AFAIK the actionPackages element is only for zero-config,
annotation-based configuration. Most people don't try to mix the two, I
guess.

Dave


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message